Solved: R2A stopped recording mid-flight

I was doing a LiDAR scan over a 200-acre property which took 3 batteries. For some reason, when I landed my second flight to swap batteries, I noticed the camera shutter wasn’t clicking and when I transferred the data to my computer to take a look, only the “data” folder was there and not the other PPK PC painter, PC Master, etc.

This is very disappointing because now we have to re-do the entire project from setting ground control to the flight. This one little random error is going to cost us both time and money, so I want to ensure this doesn’t happen again.

What could have possibly stopped the R2A from recording mid-flight?

I went into the GUI to see if there were any answers when it landed, but it gave some kind of message like recording not available, please shut down ~~ or something like that. And, the USB definitely had more than enough space. Also, just 2 days earlier I did a 150-acre+ scan with no issues so I really don’t get why this happened today.

Any advice or thoughts will be greatly appreciated.

Couple of things here.

  1. the data captured is not lost, if you have the [data] folder you can recreate a new ppk.pcmp file by creating a new project and selecting ALL of the .data files. You will need to grab a screenshot of the boresight values from the GUI of the R2A and add those in manually to the project. Same thing applies for the ppk.pcpp file it will prompt you for all the files that it needs. (Note: ppk.txt is your trajectory file in the [ins] folder)

  2. Likely what happened is that you didn’t format your USB drive and even though the space was cleared it was still fragmented and that caused a buffer issue and that it likely the reason your capture was force stopped. It is certainly a good practice to start with a formatted USB drive. Easily done in the storage tab of the GUI.

I don’t think it captured all the data because 2 days before this flight, I did a 150-acre scan which totaled 37gigs. This was a 200 acre property which only yielded 20 some gigs. Like I mentioned, I noticed the camera shutter stopped clicking which made me think it stopped recording data, and when I checked the file it seemed to be the case.

Question: Does the USB need to be formatted before every flight? Because we already formatted it on the GUI when we did the previous job.

Also, one more thing to add. We did go back and re-scanned the property. This time, we did not use the GUI and manually pressed the button on the R2A and it recorded everything without issue. Could it be the GUI that is causing this issue?

I would recommend starting every job with formatting the USB stick.
Also, it may be beneficial to configure it for taking as few pictures as practical. If the speed is low, then taking a picture every 2 seconds may be too much overlap.

1 Like

Thank you, we will start formatting before every flight. What would be the recommended picture interval with a 6m/s flight speed?

It really depends on AGL. I would say the rule of thumb for colorization would be 25% overlap. The vertical FOV of the camera is ~40 degrees, which is 36 m along the flight path at 50 m AGL. 25% overlap between two subsequent images would be 9 m then. That means, the distance between the two image centers will be 18+18-9 = 27 meters. At 6 m/s flight speed that would be 4.5-sec interval. If you fly higher, the interval can be proportionally longer.
UPD: One catch though is if you have some tall objects you don’t want to miss. Then you would use the AGL minus the height of those objects instead of AGL in the calculations above. Although, usually overlap covers those unless they are really tall.

1 Like

M300 RTK / R2A / Reach RS2 platform.

We’ve now experienced on 3 different missions where upon during a battery hot swap landing, we no longer heard the camera clicking. With the initial launch, all systems were operating correctly and we waited a minimum of 13-15 clicks prior to launch. We also reformat the flash drive every time once the R2A has fully powered up (for every new mission).

Typical mission parameters:
50m AGL
5m/s speed
50% side overlap (our flights are over “heavily dense” land w/ground vegetation)
2-sec camera interval (5-sec yielded blank spots on colorization)
manually start R2A recording prior to initial launch

No visible or apparent reason glaring to us, as we meticulously ensure all systems are operating correctly prior to any launch. After realizing this issue, we restarted the mission to make sure we collected data for intended area.

Any thoughts and/or is this isolated to us?


Did you have your wifi connected during the duration of your flight? This is a known issue that will be addressed with the next upcoming firmware version, however in the meantime it is best to disconnect from the R2A’s wifi after you start your mission in order to alleviate the chance of the wifi trying to reconnect mid mission and causing a force stop.

Refer to this article for a more technical explanation.

with the distance the M300 is from launch location, I would be shocked if wifi was still connected throughout the flight, so my guesstimate answer would be no on wifi connectivity during flight.

we’ll take that advise and reconfirm wifi is disconnected immediately after launch. Will post after next mission with update.


Mine did this too. I am working with them on it. I hope to test tomorrow with the memory card formatted via the R2A.

It works every time if you just do everything manually (without connecting to GUI). Hopefully they update this soon.

*I always disable my phone wifi before starting up R2A as well.

1 Like

Just did a test flight with it being formatted on the r2a right before flight and then turning my wifi off and using the buttons only and it seems to have worked fine.

We are working on some best practice documents for users to keep with them or their LiDAR units. The idea being to mitigate as many of these small error type things. In the meantime just keep in mind that you are putting highly sensitive important data onto your solid state media (USB memory) and it is important to remain diligent about your USB maintenance.

For that reason we are recommending that you format your USB using the Rock LiDAR GUI web interface prior to every data capture.

1 Like

I am going to have to do this from now on. Using the wifi is the only explanation as to why my camera stops. The lidar scan is there and goo but no photos for rgba info.

It is highly recommended that you listen for the clicks when you start your unit. There is a known firmware glitch that extremely intermittent it prevents the Sony A5100 camera from initializing and therefore won’t take pictures for the duration of your collection. Easy solution: Listen for the clicks, if you don’t hear them then restart your unit and you’re good to go.