ROCK Desktop "unknown error"

I am having a problem at the “Process Point Cloud” section on ROCK desktop. My trajectories process fine with no errors, I get to the visualizer, adjust my scan lines, frame gate and distance gate to display all my data, click “next” bottom right, then “Process”. It had ran anywhere between 8% and 41% before it quickly jumps to 100%, then displays “Process exited with an unknown error. If it continues to happen, please contact support.” Support has been contacted, but i also wanted to ask the community and see if anyone else was experiencing the same error.

Some Notes:
   I was able to successful generate a PC the first time I ran this. However, I had not adjusted my distance gate on PC Master in quite some time, so upon final review of my colorized cloud, I was missing a decent amount of my data.
   I've tried reprocessing from the beginning 3 times now, all the same "unknown error" result.
   The data was collected with an "out of date firmware" (hardware is an R360). It has been since updated, and not believed to be part of the problem, as i was able to get through my first time processing it successfully. 

I’ve read the entry about Cloud Servers (we use OneDrive), so I’ve even ran a process on an external SSD, still with the same error.

Your help would be greatly appreciated!

You process your data from the SSD?

I typically keep mine on my hard drive proper. This habit has eliminated some “bad habits” from the software.

In my experience, “out of date” software, while it needs to be updated, is not a death sentence.

Do you still have your virgin data, or do you keep processing the same file?

Not typically from an external SSD. I have and M.2 NVME drive (I understand this is technically still an SSD) in my PC which is where I usually save my data. Although, we use OneDrive here, which I read in an earlier article, could be my issue. That is why I tried the external SSD.

I was finally able to get the Rock Desktop to chug out my project (it is 130 acres large). It did however fail on the upload process to Rock Cloud.

I may just need to go buy another M.2 for my machine to use as “local” storages for processing.

I do still have it and every reprocess mentioned in my OP was from scratch, with similar failure points.