Questions about mission planning

I’m attaching the .kml for the operation we’re doing in the next few days. Any advice would be appreciated.

We have 3 sets of m300 batteries.

DJI Pilot says this operation will take 2h 30min at 60m

  • Should we break it into 2 pieces (North, South)?
  • Do we keep the base station at the same location for the entire operation?
  • Do the 2 sections need to have a lot of overlap in order to stitch together later?
  • Any tips on control point distribution? We likely won’t be able to get back in the trees very well. We can place a few along the road on the west side.
  • I have never done terrain follow in the m300 before. If we can’t get good rtk up there, what is my best option? (I’ve got the mission planned with a DEM right now but if it doesn’t work…)

Thanks in advance…

Do you have means of charging your M300 batteries in the field? If possible it would be most ideal to run base in a central location for the entire time from while you complete the entire survey. As long as it is within the acceptable range it should work great!

If you haven’t used DEMs with DJI Pilot it would behoove you to test it before tackling a mission of this size, as there is a bit of a learning curve and you clearly want to maximize your battery as you’ve got a 7 mile area to fly.

A few notes on your proposed mission:

You want to be sure to have a high point if possible to fly the entire area from one spot.

The complexity of this mission would probably be better handled using UgCS instead of DJI Pilot, however that will introduce a large learning curve and definitely the need for some testing. It is also worth noting that you will need a laptop running the UgCS Client as well as a hotspot for the laptop and the smart controller to be connected to for the duration of mission.

1 Like

Wow that’s a long collection. :slight_smile:

We fly with 4x battery sets and the charging case with a little generator for our M300. So far, we have only gotten 5x hot swaps (6 flights total) with that setup (~1.5hr in DJI Pilot). Then we take an hour break to transfer data, eat something and let the batteries/charger catch up… then do it all over again. So far we have been able to do this 3x per day (nice long summer days).

Base station can stay where it is unless you have security concerns and want it close by. In general you are clear to roughly a 10km radius, out beyond which you may start to see 2-3cm of separation. Although, watch your battery drain on the RS2 or what ever base you’re using… we usually hook up a simple USB battery bank to it to provide that all day power security.

Overlap: DJI Pilot is so wasteful on the edges you’ll have no problem with enough overlap. That said, you shouldn’t really need much of any overlap to merge anyway given that both data sets are calibrated. ie running strip alignment on the R2A isn’t particularly useful given its internal accuracy, hence overlap only serves to verify accuracy not augment it. Though you could use the global shifting in RockCloud if you see a simple issue.

GCP distribution: if you want an orthomoasic, that will govern the GCP distribution. But you’d be in 2D ortho mode so not nearly as stringent as say a normal photogrametric flight. We default to 3-5x per flight group (how many hot swaps we can do), and just spread them around to each unique part. That’s gonna be tough in your area.

As for the DSM in DJI Pilot, we are testing our first run of it tomorrow. It is a bit of a learning curve though. So be careful.

Best of luck :slight_smile:
Please share any lessons learned on the DSM part. :wink:


Thank you so much for your response! We’ve been out in the field doing the survey above and we had a lot of mixed results with both aircraft and R2A unit.

First - M300 issues…

Using the DEM through DJI Pilot to create the mission worked in the end. It slows down and frequently crashes after opening the DEM. It also changed the flight path angle every single time I adjusted anything so it had to be the very last step after importing the DEM. Smaller, rectangular test areas didn’t have this problem but if the survey area is a strange shape, Pilot seems to have it’s own idea of which angle you should fly. Flights with the DEM were not at the altitude I set. If I set it to fly at 120m it would go up to 150… If I set it for 90 it would go at around 125. We had more than 100m of elevation change in our survey area so I didn’t want to risk hitting the hills and kept it up pretty high like that. It didn’t seem to matter if I was flying with or without RTK, the altitude was still off by ~30m.
On our first several flights we weren’t able to hot-swap. At some point during the flight I would get a red error that had something to do with the RTK and GPS disagreeing (even if I was flying with RTK positioning off). The error didn’t seem to affect the flight at all but required a restart of the drone before it would allow takeoff again. So each flight required a calibration step etc. I got my practice in and I must say my figure 8’s are quite smooth :wink: On our second day of flying we didn’t get this error and were able to successfully hot swap but the ground following distance increased to 40m above where I set it. So far, I think any flights using DJI pilot and the DEM are going to require a test battery to see what it’s actually going to do. The forward movement of the aircraft slows to almost a stop when changing altitudes frequently and it definitely made the operation take a LOT longer than if flown at a constant altitude. The trees were so dense and there were very few clearings. I was only able to maintain video signal up to about 1-1.2km away and control link would quit at around 1.5km depending on terrain. We only had 1 slightly scary RTH where we lost sight for a bit. We had random battery errors where the charger refused to charge them but they came up as ok in the aircraft. After a short flight they went back to normal, but I don’t know what caused the error. All of our batteries have less than 10 charge cycles. So I’ve learned some of the quirks and limits of the aircraft. Still a lot of bugs and errors in DJI Pilot. (Does it show your (incorrect) speed in km/s like it does on my screen?).

Issues with R2A unit:

After a full day of flying I started processing data and one section wouldn’t come together in the PCMaster software. It shows the calibration flight and then about 10 seconds of flying towards the start point but nothing else. All the data / photos seems to be in the project folder but I can’t get it to process. I was speaking with Alex and I’ll be sending it to them to see what went wrong. In the meantime I ended up re-flying that section.
Another section didn’t work at all. When I looked at the folders, about 1/3 of the data files were 0kb. So the R2A unit stopped logging data sometime after the battery swap but there was no indication of issues until I saw the data. The log file wasn’t created either so I don’t have any hints as to what went wrong. I did the startup / shutdown properly (same as for many sections that worked) but a large chunk of the data was corrupt. I don’t know if this will happen again but I’m going to have to look at files immediately after landing to make sure they all have data in them. I ended up having to fly this whole section again the next day which was a huuuge pain because the road was almost impassible and getting the equipment in and out took a long time. I formatted the memory stick and on our second day there were no data glitches that I can tell.
The wifi on the R2A unit seems pretty unreliable. I had mixed results using my phone so I usually just operated the unit with the button. On our last flight, I used the laptop to log into the WiFi (in order to format the memory stick). I also used the web interface to start the data capture. The flight was 2 sets of batteries and we did a hot swap. At the end, I tried to log back into the WiFi but it wouldn’t show up on any of my devices as if it had stopped broadcasting at some point. Not sure what’s going on there but it would be nice to be able to connect via WiFi reliably and quickly.

I think that’s it for now. I haven’t started uploading data to the cloud yet so wish me luck!

The M300 R2A wifi issue is intermittent and we know about it. It is due to the M300’s 2.4 signal interfering with the R2A wifi. Our engineers are looking into it and hopefully will have a solution with the next firmware release. The workaround is super simple in that you just use the button to start/stop and shutdown (single press, single press, 3-4 seconds hold to trigger shutdown).

In regards to your failed data capture after a hot swap. Is it possible that power was temporarily lost to the R2A during the hot swap? That is about the only logical explanation as to why it would stop capturing data mid mission. I am curious if you were still hearing the camera clicking after the swap?

You have the right idea with confirming your collection while you are in the field. In fact that is one of the very best things about the R2A! You can always open the RTK.pcmp file without the base station data to confirm your capture on a laptop immediately after you shut down the R2A. I’ve found this to be an invaluable tool to confirm our collections on site without needing to disturb my base station collection.

As this was your first job with the R2A/M300 combo, hopefully these hiccups will iron themselves out with a little more experience. We all look forward to seeing what you’ll collect in the future, and kudos for tackling such a big job out the gate!

1 Like

I definitely heard the camera keep going throughout the battery swap. The camera was still clicking after landing at the end of the mission as well. I used the button to shut down… waiting several camera clicks before doing anything and I waited a minute or so before shutting down as well. The timestamps on the data files show that it kept attempting to write files throughout the mission but the last 1/3 of them were corrupted with 0kb. I think the data stop happened sometime during the second part not during the battery swap, This seems a lot more like the drive was somehow corrupted. I did not format the drive when I received the unit because there was a lot of space on it and I didn’t know if the files that were already on it were important. I’m still planning on uploading the corrupted files for your engineers to have a look at.