PM Master failed to finish processing Trajectory

i have made several attempts to generate a las file with PC Master. i have had several successful attempts prior to this one and all is well. i get past the part where i enter the correct coordinates of my base and it begins to process the trajectory. PC Master shuts down, according to the PPK report, when it starts processing the tightly coupled trajectory.

any thoughts/help would be appreciated!

Josh

Josh:

I’ll dig through your PPK report and try processing it on my end. I’ll post to the community what I find for other users who may encounter the same issue.

1 Like

good deal. thank you!

I am having this issue too…
I am using the “newest” software, but have not updated the lidar, yet.

I did 3 missions yesterday, all on the “old lidar firmware”… I only updated the software this morning as I was trying to fix my other data… well, it was not the software!

Now it will process, right to the end, but won’t couple the tightly coupled trajectory.


this is the last lever arm refinement and then it gives me the attitude separation and then nothing. we loaded the base file into trimble and we have good data there. it appears that we have good data on the IMU measurements and were getting continuous measurements on GNSS velocity. so not sure what that +/-25 minutes of straight is.

this was a total flight time of about 90 minutes. we hot swapped 4 times. we flew 1200 acres in 2 days and we hot swapped 5 times each day. didn’t have any problems getting that data to process. I would be willing to say that its probably user error on my end as I have only been flying the R2A for 2 weeks now.

Interesting… when I got those “straight” lines, there was NO gnss signal, or it was blocked. I’ve only ever seen this during R2A terrestrial scanning under weird places.

User error… I’ve learned (and I teach) that with this style of flying and survey, there are 10 levers to pull and each lever has 10 points that need to work in perfect synchronicity for this to pull off. I’ve been using the R2A full time now for 6 months and it still amazes me.

As for my data problem, I rebooted (again, sigh, third time today), re-started the processing and watched/prayed… and it worked!

awesome!

we were in the wide open at a water treatment plant under construction. we did have some 138kV lines about 250’ from our setup which we had to cross every time we swapped. but i flew 6000’ of 2 runs of 345kV yesterday and had no problems with the processing. i will say the last time i tried to run this particular set it made it to 90% on the first try tightly coupled and then crapped out. that was the farthest of like 5 or 6 attempts.

Hi @Joshsrvy
Okay, knowing some stuff about how INS works, I was asked by RR guys to take a look at the trajectory files. What I found was that Inertial Explorer crashes too when trying to process these files. And the other indication of issue was this middle part where it could not obtain integer-fixed solution with RS2 as the base. However, when I downloaded the CORS data from TXBN base 25 km away and used it instead of the RS2 data, I was able to process the trajectory with no issues (although the position accuracy may be ~2cm worse). There appear to be some issues with Doppler data from the RS2 in the dataset. There may be PPK settings that would allow to process it, I am still looking. May have something more tonight.

so you believe it was the base that had a period of bad collection or non collection?

I’ve had my base collect bad data three times… twice it corrupted in the field (wide open spaces) and once it ran out of battery power (the aux battery did not show up to work that day either).

I like the CORS data trick… My first real experience had the base station 50km away. The data was sloppy. The other time, the base station was very close (<5km) and there was no issues with the data.

It happens… knowing there is an alternate solution to try is comforting.