LiDAR Capture stopped mid-flight

I had a flight last week and everything seemed to go fine. I checked the R2A upon landing and saw it had captured imagery, lidar, etc. What I did not notice is that it was less than there should have been. Apparently the unit just stopped capturing data midflight. It did not turn off, it was on when I landed and I saw it had taken 400+ images, etc. Upon processing I now see it just ends about 1/3 of the way through the mission. The images line up as well. I’m going to refly tomorrow hopefully just want to make sure if this is an issue.

Hey @Daniel! Well, that doesn’t sound good. When you say it processed, but only 1/3 the way through, do you see only 1/3 of the trajectory on PCMaster? or do you see the whole trajectory and only 1/3 of the LiDAR data is populated? If you can include some screenshots that would be great!


Only 1/3 shows up in PC Master. It shows my takeoff, figures 8’s, and the flight up until it just stops. The lidar seems fine up until that point. Images look fine too, then poof. I had no loss of signal, no app crashes, nothing like that. It was a single battery set mission and the RTH was initiated at the end of the last line or so, nothing weird.

Well Daniel, This does look like a problem that we will need to have the : INS folder, sys.log file and the Base Station file. Can you send this to and we will get right on it. After we look into the issue, I can write on here what the issue was and get the problem fixed.


Hey Daniel,

We ran through the project file you uploaded and haven’t reproduced the error. The one thing we did was to delete the processed ppk.txt trajectory and reprocess. We will still see if we can reproduce this error.

In General: PCMaster will take the raw gps+imu + base station and computes the trajectory first and saves this trajectory in the INS folder under the name ppk.txt and will also update the PPK.PCMP and add the ppk.txt as a file to the project file. If there is an error though, you can trigger PCMaster to recompute the trajectory by deleting the ppk.txt file in the INS folder and and remove the reference in the ppk.pcmp file.

Next time you open the project file, it will fail to locate the trajectory and reprossess.

Thanks. I have tried once with no luck, still showing only part of the flight. I am redoing again to see how it goes. If you have a .las available I would happily take it… I cant remember if I sent you all the data to produce though

Every time I delete the text file and reprocess it does this. I will hold off on reflying but need some help or if you could just send me the las file I’ll get it uploaded and processed in the cloud.

I have tried 4 different times. I tried from the link I sent you using the steps above, a full restart from the original files twice, and deleting the text file from one of those restarts. It always does this. Frustrating. About to go do another flight

Daniel, are you using the latest PCMaster and firmware? I had an issue like that before but never again.

@Daniel as @laserboy mentioned, be sure to check that you are using the latest PCMaster.

If you have the latest software, then it could be a limitation on the resources of the processing computer. You can test whether you are having resource limitation issues by using the command line interface to PCMaster. See

The command line interface uses less system resources since it doesn’t have to load the GUI.

I will produce a las and upload it to the cloud for you.

1 Like

I am on 2.1.0 and - will update - wish I just got an email when new firmware was out. I just got my first email notification from a project being done last week

@Daniel if you use the ‘Watch’ feature on this post: ROCK robotic Software Releases then you will receive email notifications when a new release is available.

1 Like

awesome. thanks for letting me know!

1 Like