Camera keeps stopping

I have been having intermittent problems with the camera stopping (R2A) after about 1-2 minutes.
It typically happens about 1 in 4 or 1 in 5 flights. All the LiDAR data will be there but only about 25-40 pictures.

I am on all the latest firmware.
I always format the USB as per instructions.
I always shut off the wifi and start the unit manually.

This makes most operations take at least 2x as long as they should because I have to re-do segments all the time.

To be honest. I have never had a reliable experience with the R2A. It’s been back for repairs twice and I have never been able to rely on it enough to leave a job before uncompressing and processing the RTK at least.

We are just about to enter our busiest season and have several jobs lined up in the next few weeks. Yesterday was a total fail. We had a corridor operation of about 20km. This should have been a 3 flight operation.

The first leg worked as it should. The second leg worked fine. Then on the 3rd, the camera stopped. We spent the rest of the day charging batteries and running flights but all were the same. The camera would stop within the first few minutes and of course there’s no way to know until we land the drone and sadly the camera isn’t running.

It’s like an awful lottery. Every time I touch down I’m terrified to approach an not hear clicking.

Is yours the original R2A, or the snappier R2A no strings version?

Hello, DroneCanada! We will continue to assist you via the Support Ticket you created with the ROCK Support Team. Thank you!

We had an original, but we experienced some issues and it was replaced with a No-strings version after some strange problems.

I have had 2 successful flights with a different USB stick now. The original USB doesn’t seem to have anything wrong with it and still performs fine on a PC diagnostic R/W test etc.
This is an intermittent problem so we’ll have to see. Problem is, we’re booked every day there’s good enough weather to fly so it’s hard to find time to test.

I was able to finish my project from the other day by colourizing the point cloud in Metashape using photos taken on another run. Luckily the colour alignment isn’t that important on this job. It turned out surprisingly well though!

We had an issue with it the first run when we got ours but otherwise no issues with ours!

1 Like

We have an original R2A that the camera has stopped and was told they will not be getting any camera parts in to repair. Hoping they have some other solution to add a camera to a unit less than two years old.

So I’ve been back and forth with support and I haven’t received any actual reason or cause for the issue. There are some firmware updates that came out recently so I’ve updated to that.
Today I flew a 1 battery operation that completed sucessfully.
The next part of the survey was a large area in a forest. It was really difficult but we completed it in 3 batteries. When I got back, the camera was still clicking. I pressed the button on the unit to stop the operation and the camera stopped clicking.
Then I held it for 4 seconds to shut down but it didn’t shut down.
So I logged into the WiFi and attempted to shut down from there.
It gave me an error that I needed to stop data collection. So I clicked on the stop button and then shut down.
When I looked at the folder there was a DATA folder full of files but nothing else. No INS or Camera folders or any other files.

This job is a 4 hour drive from home and I’m going to have to somehow come back when I have a reliable LiDAR unit.

I am really frustrated with the R2A and the lack of reliability. I always have to assume that it will fail and plan to spend at least 2x the needed time on site.

I don’t know what even could cause this. I go really slow and try to make sure that I do all of the steps exactly right every time. I format the memory stick. I’ve replaced the memory stick with a brand new one.

The only thing that seems consistent is that it usually works the first time. But every flight past the first I get about a 50/50 success/fail ratio.

I have successfully recovered files from an incorrect shut down (although it is not your fault).

1 Like

This method should work. If you have your logs from this flight, please send them in!